Frage:
Warum bricht das Gespräch sofort ab wenn ich via Softphone Mobile (LTE) einen eingehenden Ruf annehme?
Fehlerbild:
Sie erhalten einen Ruf auf Ihr Softphone Mobile Device im LTE. Der Ruf wird signalisiert und Sie heben ab. Direkt nach der Annahme bricht die Verbindung ab und man bekommt die Push Nachricht des verpassten Anrufs.
Hinweis: Bisher ist das Fehlerbild nur unter Nutzung des Telekom Providers aufgetreten. Die Lösung gilt speziell für diesen Fall.
Ursache:
Schneidet man einen solchen Call im Wireshark mit und sieht sich die SDP Header der Call Legs an, kann es vorkommen, dass entweder bei einem der Call Legs keine Kandidaten oder nur IPv6 Kandidaten gesendet werden.
Hinweis: Im Folgenden wird diese Analyse nur grob erklärt, für eine genauere Information wie man sich die relevanten Informationen heraussuchen kann lesen Sie bitte den Unterpunkt „Wireshark Analyse“ unseres Troubleshooting Guides: https://github.com/C4BCSMORG/Dokumente/raw/main/KB/XPhone_Connect_Softphone_Mobile_Troubleshooting.pdf
Hier der Screenshot von den Kandidaten des XCC (Gutfall):
Die rot umrandete Zeile zeigt Ihnen von wem die Kandidaten sind. FREESWITCH ist unser XCC, IceLink wäre ein Client (egal ob Mobile oder Desktop).
Die FREESWITCH Kandidaten finden Sie im Invite - SDP, die Kandidaten der Clients im Session Progress - SDP des Calls.
Sind bei diesen Client-Kandidaten nur IPv6 Adressen hinterlegt oder fehlen die Kandidaten, so kann für die Fehlereingrenzung / Lösung die APN Einstellung des Smartphones angepasst werden.
Lösung
Konfigurieren Sie die APN Einstellung so, dass Protokolle im APN von IPV6 auf IPV4 umgestellt werden.
Die APN Einstellungen finden Sie typischerweise in den Unterpunkten der SIM-Karten Einstellungen des Endgerätes, abhängig von der Betriebssystem Version.
Beispiel Android:
- Öffnen Sie als Erstes die "Einstellungen"-App auf Ihrem Android-Smartphone.
- Unter der Kategorie "Drahtlos und Netzwerke" oder "Netzwerk & Internet" finden Sie den Punkt "Mobile Netzwerke".
- Tippen Sie auf die Option "Zugangspunkte", können Sie einen neuen APN einrichten.
- Tragen Sie als APN die Adresse „internet.t-d1.de“ ein und speichern Sie die Einstellung. Mit dieser APN Einstellung erhalten Sie eine öffentlich erreichbare IPv4 Adresse, wenn Sie sich mit dem Mobilfunk verbinden.
Beispiel IOS:
- Öffnen Sie als Erstes die "Einstellungen"-App auf Ihrem IOS-Smartphone.
- Navigieren Sie zur Kategorie "Mobilfunk" und dann zu "Mobiles Datennetzwerk".
- Bearbeiten Sie den APN "Mobile Daten".
- Tragen Sie als APN die Adresse „internet.t-d1.de“ ein und speichern Sie die Einstellung. Mit dieser APN Einstellung erhalten Sie eine öffentlich erreichbare IPv4 Adresse, wenn Sie sich mit dem Mobilfunk verbinden.
Sollte Ihnen dieser Artikel nicht weiter helfen, so werfen Sie doch einen Blick in unseren Troubleshooting Guide für Softphone Mobile: https://github.com/C4BCSMORG/Dokumente/raw/main/KB/XPhone_Connect_Softphone_Mobile_Troubleshooting.pdf
Kommentare
0 Kommentare
Zu diesem Beitrag können keine Kommentare hinterlassen werden.