Question:
Why does the call drop immediately when I answer an incoming call via Softphone Mobile (LTE)?
Error pattern:
You receive a call on your softphone mobile device in LTE. The call is signaled and you pick up the phone. Immediately after answering, the connection is interrupted and you receive the push message of the missed call.
Cause:
If you cut such a call in Wireshark and look at the SDP headers of the call legs, it can happen that either no candidates or only IPv6 candidates are sent for one of the call legs.
Here is the screenshot of the XCC candidates (good case):
The line outlined in red shows you who the candidates are from. FREESWITCH is our XCC, IceLink would be a client (whether mobile or desktop).
The FREESWITCH candidates can be found in the Invite - SDP, the client candidates in the Session Progress - SDP of the call.
If only IPv6 addresses are stored for these client candidates or if the candidates are missing, the APN setting of the smartphone can be adjusted for error containment / solution.
Solution
Configure the APN setting to change protocols in the APN from IPV6 to IPV4.
The APN settings can typically be found in the sub-items of the SIM card settings of the end device, depending on the Android version.
Example Android:
- First, open the "Settings" app on your Android smartphone.
- Under the category "Wireless and networks" or "Network & Internet" you will find the item "Mobile networks".
- Edit the APN "Mobile data".
- Enter the address "internet.t-d1.de" as the APN and save the setting. This APN setting gives you a publicly accessible IPv4 address when you connect to the mobile network.
Example IOS:
- First, open the "Settings" app on your IOS smartphone.
- Navigate to category "Mobile" and then to "Mobile data network".
- Set up a new APN. Enter the address "internet.t-d1.de" as the APN and save the setting. This APN setting gives you a publicly accessible IPv4 address when you connect to the mobile network.
Comments
0 comments
Article is closed for comments.